Donations towards server fund so far this month.

 
£0.00 / £100.00 per month
Page:
Home > Help Needed / General Tech Chat > Misfire

steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

This is really puzzling me. The car has developed a high speed misfire, 6300rpm and above. It sounds like a soft cut rev limiter, and happens regardless of load. So far I have replaced the megajolt,edis, coilpack, crank sensor, plugs and leads to no avail. Also wound the mixture up and down and had the head off to check valves springs etc. Compression test as normal on all cylinders. Engine pulls very strongly below this critical speed. Any ideas from the collective?

'Where does the engine go?'


theoneeyedlizard

User Avatar

7154 Posts
Member #: 1268
The Boom Boom speaker Police!

Essex

What RPM is the Rev limit set to?

Could you do a log to see whatís happening? Maybe itís loosing crank position at high RPM.

In the 13's at last!.. Just


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

rev limiter is set to 7300, sadly I can,t do a plot. The timing is at about 38 deg at 6000, as the misfire starts the afr falls from about 15:1 but I guess that's just unburnt fuel

'Where does the engine go?'


robert

User Avatar

6583 Posts
Member #: 828
Post Whore

uranus

maybe re load the mjolt software in case it has a glitch ?

Bicester scramble ,Medusa enjoyed the trip. https://www.youtube.com/watch?v=Q-7I7-nA19U


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

In the early stages of this Robert,I discovered my old V3 was dying (13 years old) so upgraded to a spanky new v4,reloaded the map and off she went,but still the misfire.

'Where does the engine go?'


gr4h4m

User Avatar

4868 Posts
Member #: 1775
Post Whore

Chester

Is it loosing the crank signal?

I run a supercharger and I don't care the TB is on the wrong side.
VEMS + 12 PSI + Liquid Intercooler = Small Bore FUN!


Joe C

User Avatar

12232 Posts
Member #: 565
Carlos Fandango

Burnham-on-Crouch, Essex

apart from loosing the crank signal, you could be loosing synch between the Edis box and the jolt, which would mean it falls back to the 10 degree inbuilt timing, that should show up as loosing rpm in the jost software,

On 28th Aug, 2011 Kean said:
At the risk of being sigged...

Joe, do you have a photo of your tool?



http://www.turbominis.co.uk/forums/index.p...9064&lastpost=1

https://joe1977.imgbb.com/



steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

The rpm and advance are stable into the misfire so I don't think I'm losing the crank signal. Is it possible to get advance as per map on the jolt readings but have the engine seeing edis fixed timing?

'Where does the engine go?'


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

The rpm and advance are stable into the misfire so I don't think I'm losing the crank signal. Is it possible to get advance as per map on the jolt readings but have the engine seeing edis fixed timing?

'Where does the engine go?'


jbelanger

1248 Posts
Member #: 831
Post Whore

Montreal, Canada

Make sure you're using resistor spark plugs.

http://www.jbperf.com/


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

Yes, same plugs I've always used, swopping between sets made no difference.

'Where does the engine go?'


Turbo Phil

User Avatar

4425 Posts
Member #: 20
My sister is so fit I won't show anyone her picture

Lake District

38 degrees timing at 6,000? Is that a misprint? Is this a boosted motor?

Phil.

WWW.TURBO-MINI.COM


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

That's at no load Phil, it's about 17 at full load.

'Where does the engine go?'


Turbo Phil

User Avatar

4425 Posts
Member #: 20
My sister is so fit I won't show anyone her picture

Lake District

Ah ! Makes more sense.

Phil.

WWW.TURBO-MINI.COM


robert

User Avatar

6583 Posts
Member #: 828
Post Whore

uranus

perhaps try new earth leads , also a direct from battery to 12v coil supply to eradicate any ign switch or wiring problems ?

Bicester scramble ,Medusa enjoyed the trip. https://www.youtube.com/watch?v=Q-7I7-nA19U


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

I did try putting a second battery on in case I was losing voltage. my next move is to replace the lead from edis to mj including the earth connections.

'Where does the engine go?'


robert

User Avatar

6583 Posts
Member #: 828
Post Whore

uranus

crank sensor bracket not cracked and vibrating the sensor away from the wheel ?

Bicester scramble ,Medusa enjoyed the trip. https://www.youtube.com/watch?v=Q-7I7-nA19U


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

Will check Robert, I have replaced the sensor, would expect a loss of crank position to mess up the tacho reading?

'Where does the engine go?'


gr4h4m

User Avatar

4868 Posts
Member #: 1775
Post Whore

Chester

I had an issue when I first installed MJ, the sensor wire wasn't sufficiently shielded and it caused a number of strange running issues, that and the gap were critical.

I run a supercharger and I don't care the TB is on the wrong side.
VEMS + 12 PSI + Liquid Intercooler = Small Bore FUN!


tadge44

2970 Posts
Member #: 2500
Post Whore

Buckinghamshire

Steve, I think your last post is in the right direction. You and I have had similar issues in the past with these connections, remember ?


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

Yes David, and I've had others since! *Confused* *happy*

'Where does the engine go?'


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

So after a few diversions, i can report as follows: changing every element of the ignition system has no effect. The jolt is talking to the edis, as timing on the crank is correct, and moving the rev limiter speed also works. Tried a thick damper oil in the carb to no effect. The problem is worse before the engine is fully warmed up, starting around 5000rpm, and also worse if the engine is sharply revved as against a slow increase. Is it fuelling related after all?

'Where does the engine go?'


Tom Fenton
Site Admin

User Avatar

15246 Posts
Member #: 337
Fearless Tom Fenton, Avon Park 2007 & 2008 class D winner

&

TM legend.

Rotherham South Yorkshire

Do you have a wideband lambda sensor fitted, what does the fuelling do?


On 29th Nov, 2016 madmk1 said:


On 28th Nov, 2016 Rob Gavin said:
I refuse to pay for anything else


Like fuel 😂😂


steve1275

User Avatar

778 Posts
Member #: 951
Post Whore

Bromsgrove

Yes Tom it goes from 12/13 to 10/11 as the misfire begins.

'Where does the engine go?'

Home > Help Needed / General Tech Chat > Misfire
Users viewing this thread: none. (+ 1 Guests)  
To post messages you must be logged in!
Username: Password:
Page: