Donations towards server fund so far this month.

 
£0.00 / £100.00 per month
Page:
Home > A-Series EFI / Injection > SPI none start 1995

jimmy

1292 Posts
Member #: 829
Post Whore

essex

Hi All

Long time no speak i have a 1275 SPI mini not start you can put fuel down the inlet turn the engine over and it starts i have no power output from the brown/grey wire on the cut off fuel switch which is on the n/s next to the rad if i put power to the brown / grey wire it will fire up the pump but when you crank the engine over it still not starting i have replaced the relay unit (little black box) and replaced the fuel pump about 8 weeks ago any one got any idear

1293 turbo mini


e5tus

User Avatar

301 Posts
Member #: 10128
Senior Member

Dorset

When you power the pump you are getting fuel at inlet?


Rod S

User Avatar

5977 Posts
Member #: 2024
Formally Retired

Rural Suffolk

As above, does the pump actually pump and pressurise the system when you power it up ?

I once had an SPi Metro where the pump would show 12V but got clogged up internally so didn't actually flow any fuel.

I don't know how they fit in the tank in the Mini but in the Metro I had to cut a circular hole in the boot floor to take it out if the tank - the recess was clearly pressed into the boot floor but Leyland never actually made it a sealed openning, just solid metal....
Dismantling the pump was a pain, the end was O-ring sealed but crimped in place but once open, it was just corrosion from the steel parts of the motor windings that were causing it to stick (damp petrol ? as the motor runs in the fuel).

Schrödinger's cat - so which one am I ???


jimmy

1292 Posts
Member #: 829
Post Whore

essex

i have got to the bottom of it i had a spark and i had fuel but would not start it turned out to be the injector (SPI) model had stopped work what i did was remove the black plug and wired a LED lamp to the black plug on the loom so when you cranked the engine the lamp flashed so i removed the injector to find it was blocked with shit blow out with air line put it all back turn the key and it started straight up *Clapping*

1293 turbo mini

Home > A-Series EFI / Injection > SPI none start 1995
Users viewing this thread: none. (+ 1 Guests)  
To post messages you must be logged in!
Username: Password:
Page: